Составляем запрос, в полях которого присутствуют строковые поля. При попытке упорядочить/сгруппировать по этим полям возникает ошибка Недопустимое поле для упорядочивания» / «Недопустимое поле для группировки».
Причина ошибки в том, что система видит данные поля как поля неограниченной длинны и поэтому не может по ним упорядочить значения.
Для устранения ошибок необходимо выразить значение в строку с явным указанием её длины. Для этого применяется метод ВЫРАЗИТЬ.
Например:
ВЫРАЗИТЬ(НаименованиеПолное КАК СТРОКА(200)) КАК НаименованиеПолное
Добавить комментарий